ANZEIGE:
Forum » Liga » Probleme » Easy Anti Cheat

Easy Anti Cheat



#1 vor 20 Tagen
nils.hce Threadersteller 1 Beitrag
Hallo
Easy Anti Cheat
Ich hab in der letzten 99dmg Saison gespielt und bei den letzten Machtes Probleme mit dem Anticheat gehabt.
Also ich hab den Anti Cheat gestartet und dann Csgo dann bin ich auf den Sever und nach so ca. 20 Sekunden stand oben rechtes Anti Cheat can´t connect to the sever und dann wurde ich vom Sever geschmissen.
Kennt jemand das Problem ?
bearbeitet von nils.hce am 05.03.2019, 13:04
#2 vor 19 Tagen
sh0rtround 16 Beiträge
hab seit der neuen saison das gleiche problem. nie probleme vorher gehabt und jetzt auf einmal kann ich nich mehr zocken. beste tool!
EAC testseite sagt "connection successful".
bearbeitet von sh0rtround am 07.03.2019, 18:40
#3 vor 18 Tagen
Ghos7 1048 Beiträge
Welchen Router habt ihr
#4 vor 18 Tagen
sh0rtround 16 Beiträge
Gar keinen. Hab ein Modem und eine Sophos UTM. Bin gerade dabei das Log auszuwerten. Es wäre halt mal geil wenn man von EAC mal erfahren würde welche ZielIPs und Ports man erreichen muss.
#5 vor 18 Tagen
iamthewall 4249 Beiträge
sh0rtround:Gar keinen. Hab ein Modem und eine Sophos UTM. Bin gerade dabei das Log auszuwerten. Es wäre halt mal geil wenn man von EAC mal erfahren würde welche ZielIPs und Ports man erreichen muss.


und dann wunderst du dich ernsthaft über Probleme bei einem Gaming-Tool, das für sowas nicht ausgelegt ist?^^
#6 vor 17 Tagen
sh0rtround 16 Beiträge
iamthewall:
sh0rtround:Gar keinen. Hab ein Modem und eine Sophos UTM. Bin gerade dabei das Log auszuwerten. Es wäre halt mal geil wenn man von EAC mal erfahren würde welche ZielIPs und Ports man erreichen muss.


und dann wunderst du dich ernsthaft über Probleme bei einem Gaming-Tool, das für sowas nicht ausgelegt ist?^^


Was bitte soll das heißen? Ein Gamingtool was für sowas nicht ausgelegt ist? Was soll denn das eine mit dem anderen zu tun haben?! Was soll denn "sowas" sein? Eine Firewall? was meinst du denn was dein Router zu hause macht? Der blockt von Haus aus erstmal den gesamten Traffic der von draußen kommt. Macht meine FW auch. Unterschied ist, meine blockt auch den gesamten Traffic von drinnen. Dafür habe ich entsprechende Ports und Zielnetze konfiguriert.
Wenn eine Software dafür "ausgelegt" sein müsste hinter einer Firewall zu laufen, dann würde die hälfte der Software auf dieser Welt nicht funktionieren.
Als ob Spiele dafür "ausgelegt" sind hinter einer Firewall zu laufen.
Als ob Faceit Anticheat, esportal Anticheat oder Teamspeak darauf "ausgelegt" wären hinter einer Firewall zu laufen.
Wenn Ports und Netze korrekt konfiguriert sind (was bei mir der Fall ist), macht es für die Anwendung ja wohl keinen Unterschied ob sie hinter einer richtigen Firewall oder einem gümmeligen Router laufen.
Eine Anwendung baut über einen Port eine Verbindung zu einem Ziel auf und transferiert ihre Daten dann über diese Verbindung hin und her. Ist ja kein Hexenwerk. Anwendung X braucht Port Y, das machst du auf deiner Firewall auf und gut.

Und nix für ungut, bei mir funktioniert JEDE andere Anwendung hinter meiner UTM genau so wie sie soll. Nur das beschissene EAC zickt rum. Und warum? Weil ihre Doku komplett für den Arsch ist. Sie sagen man muss HTTP(S) Traffic nach draußen erlauben damit es geht. Ja herzlichen Glückwunsch, d.h. wenn ich surfen kann, muss EAC auch funktionieren. Tut es aber nicht.
Und alle anderen Ansätze wie "mach mal deine Firewall / Viren scanner aus", sind der aller letzte Rotz. Das ist für mich auf einem level mit "installier mal dein Windows neu".

Ich habe mir die Logs meiner FW angesehen und zur Zeit des Verbindungsversuches auf einen EAC Server, wird da NICHTS geblockt was nicht geblockt werden sollte. Will heißen, es gibt keinen Traffic von EAC den meine FW verhindert. Und selbst wenn ich eine Any/Any Regel anlege klappt es nicht.
bearbeitet von sh0rtround am 08.03.2019, 10:28
#7 vor 17 Tagen
Maidzen 1546 Beiträge
sh0rtround:
Spoiler


Obwohl deine Kernaussage richtig ist, das hier ist 99Damge nicht Heise.de du kannst nicht erwarten das hier jemand einen Technisch korrekten Lösungsweg präsentiert.

Die meisten Leute hier sitzen als Hobby vor dem PC eine Lösung wie FW Deaktivieren ist nun mal für die meisten hier eine Lösung wenn es danach Funktioniert. (auch wenn es jetzt bei dir ein anderes Problem ist)


Mit solchen pampigen Antworten wirst du aber zukünftige eher gar keine Antwort mehr bekommen -> Du bekommst nicht mal den "doofen" Lösungsweg und kannst die Korrekte Lösung auch nicht ableiten.


Für die Problemlösung wäre interessant welchen ISP und aus welchem Bundesland. Es könnte ein Routing Problem sein.
#8 vor 17 Tagen
sh0rtround 16 Beiträge
Maidzen:
sh0rtround:
Spoiler


Obwohl deine Kernaussage richtig ist, das hier ist 99Damge nicht Heise.de du kannst nicht erwarten das hier jemand einen Technisch korrekten Lösungsweg präsentiert.

Die meisten Leute hier sitzen als Hobby vor dem PC eine Lösung wie FW Deaktivieren ist nun mal für die meisten hier eine Lösung wenn es danach Funktioniert. (auch wenn es jetzt bei dir ein anderes Problem ist)


Mit solchen pampigen Antworten wirst du aber zukünftige eher gar keine Antwort mehr bekommen -> Du bekommst nicht mal den "doofen" Lösungsweg und kannst die Korrekte Lösung auch nicht ableiten.


Für die Problemlösung wäre interessant welchen ISP und aus welchem Bundesland. Es könnte ein Routing Problem sein.


Hast du schon recht mit. Und für das "Pampig" entschuldige ich mich. Der Kommentar hat mich einfach etwas genervt. Getreu nach dem Motto, wenn man keine Ahnung hat... Wie gesagt, Sorry.
Und das mit dem "mach mal FW/AV aus" war gar nicht auf 99dmg bezogen. Das ist nur in 95% der Fälle der Lösungsvorschlag den die Leute bringen wenn man irgendwo von Problemen mit EAC berichtet. Und das kann ja nicht des Rätsels Lösung sein dass ich meine Netzwerksicherheit gefährden muss wenn ich mit EAC zocken will. Es muss ja einen Grund geben warum es ohne FW funktioniert, mit aber nicht. In den meisten Fällen fehlt da einfach die richtige Konfig. Und das ist das was ich meine, man findet selbst bei EAC so gut wie KEINE Doku dazu. Alles was ich darüber weiß habe ich mir selbst aus den Logs meiner FW zusammengesucht. Z.B. Server stehen in Irland (weden bei AWS gehostet) etc. etc.
Ich erwarte im Jahr 2019 einfach dass eine Firma die eine Software anbietet die über das Internet funktioniert, mir eine Doku zur Verfügung stellt die ALLE Infos beinhaltet die ich brauch um die Software hinter jeglicher Firewall oder Router Lösung zu betreiben. Und das tut EAC einfach nicht, und DAS ist es was mich so ankotzt, nicht dass die Leute hier oder anderswo versuchen zu helfen.

Aber zurück zum Problem.

Ich hab wie gesagt auf meiner Firewall NATÜRLICH die Ports 80/443 nach außen offen, sonst würde ja gar nix gehen. (Mehr verlangt EAC laut Doku auch nicht, wenn man mehr braucht, kann ich mich nur wiederholen, bekackte Doku).
Die Connection Testseite von EAC sagt, "Alles i.O."
JEDE andere Software die ich nutze funktioniert wie sie soll. FaceIT AC, Teamspeak, alle Games (Origin, Steam, etc), Webserver, wirklich alles ist korrekt konfiguriert. (Ich arbeite mit Sophos Firewalls mit mehreren Tausend clients dahinter beruflich, bin also nicht komplett bescheuert was das ganze angeht ;))
Als ISP nutze ich Telekom in Hamburg (VDSL 100).
Bin momentan wirklich komplett ratlos.
Hab wie gesagt gestern mal auf PVPro oder wie die Seite heißt ein paar tests gemacht, weil die ja auch EAC nutzen. Habe sogut es ging alles andere in meinem Netz deaktiviert, mir das Livelog der Firewall aufgemacht und geguckt was geblockt wird. Und da sind bis auf ein paar geblockte Verbindungen aus "Schurkenstaaten" wie China oder Russland keine Auffälligkeiten zu erkennen. Nichts was auf EAC Server oder Protokolle hindeutet die von der UTM geblockt werden.
bearbeitet von sh0rtround am 08.03.2019, 11:06
#9 vor 17 Tagen
Maidzen 1546 Beiträge
sh0rtround:Nichts was auf EAC Server oder Protokolle hindeutet die von der UTM geblockt werden.


Auf meiner FW ist nur 80/443 Freigegeben und EAC läuft. Es kann eigentlich kein FW Problem sein.
Wenn ich dich richtig verstehe sended EAC aber gar keine Requsts?

> Eigentlich passiert das Problem schon am PC, hast du Steam > EAC mal als Administrator gestartet ?
#10 vor 17 Tagen
sh0rtround 16 Beiträge
Maidzen:
sh0rtround:Nichts was auf EAC Server oder Protokolle hindeutet die von der UTM geblockt werden.


Auf meiner FW ist nur 80/443 Freigegeben und EAC läuft. Es kann eigentlich kein FW Problem sein.
Wenn ich dich richtig verstehe sended EAC aber gar keine Requsts?

> Eigentlich passiert das Problem schon am PC, hast du Steam > EAC mal als Administrator gestartet ?


Das denke ich eben auch. An der FW kann es nicht liegen.
Doch doch, EAC sendet, es wird nur nichts geblockt. Hab mir nur die geblockten requests angeguckt und da war nix bei was auf EAC hingedeutet hat.

Alles andere mit EAC und Steam hab ich ausprobiert ja. Also Alles komplett neu installiert, als Admin starten, SFC scan, und alles was sonst noch so auf der EAC Seite empfohlen wird.

Ein Ansatz ist mir gerade noch eingefallen, ich hab letztens irgendwann um etwas zu testen mal einen Transparenten Proxy auf der UTM aktiviert, an sich sollte das ja kein Problem sein, weil alles andere funktioniert ja auch noch, aber den könnte ich zum Spaß noch mal deaktivieren heute Abend.
bearbeitet von sh0rtround am 08.03.2019, 11:16
#11 vor 17 Tagen
iamthewall 4249 Beiträge
Maidzen, du solltest eigentlich wissen, dass das mein Beruf und nicht mein Hobby ist.

@sh0rtround: kein Grund, so ausfallend zu werden auch wenns mir ab und an ähnlich doll in den Fingern juckt.

ich hab mich evtl. falsch ausgedrückt: man sollte vllt nicht unbedingt erwarten, dass ein schlechtes Tool, dass schon mit den simpelsten Firewalls und AV Probleme hat, mit ner UTM-Suite einwandfrei läuft.

nicht mehr und nicht weniger wollte ich zum Ausdruck bringen.
#12 vor 17 Tagen
Maidzen 1546 Beiträge
iamthewall:Maidzen, du solltest eigentlich wissen, dass das mein Beruf und nicht mein Hobby ist.


Weiß ich natürlich :D.
Ich hab dich Überhaupt nicht Persönlich gemeint, eher allgemein auf 99D bezogen weil er "so" darauf geantwortet hat.

Egal /offtopic sh0rtround hat es ja selbst eingesehen und Probleme sind manchmal frustrierend kennen wir alle :)
#13 vor 17 Tagen
sh0rtround 16 Beiträge
iamthewall:Maidzen, du solltest eigentlich wissen, dass das mein Beruf und nicht mein Hobby ist.

@sh0rtround: kein Grund, so ausfallend zu werden auch wenns mir ab und an ähnlich doll in den Fingern juckt.

ich hab mich evtl. falsch ausgedrückt: man sollte vllt nicht unbedingt erwarten, dass ein schlechtes Tool, dass schon mit den simpelsten Firewalls und AV Probleme hat, mit ner UTM-Suite einwandfrei läuft.

nicht mehr und nicht weniger wollte ich zum Ausdruck bringen.


Wie gesagt, war nicht meine Absicht ausfallend zu werden, aber wie du ja auch schon gesagt hast, ist das mein Beruf und kein Hobby und darum hat mich der Kommentar einfach zusätzlich genervt weil er nunmal überhaupt keinen Sinn ergeben hat.
So wie du es jetzt formuliert hast, ist das natürlich etwas ganz anders. Das sehe ich dann auch komplett ein.

Ich werde es wie gesagt heute Abend nach der Arbeit noch mal ohne proxy versuchen, hab es ehrlich gesagt auch überhaupt nicht mehr auf dem Schirm gehabt dass der an war, da es eigentlich nur ein test sein sollte. Und da der auch nur Port 80 und 443 betrifft wäre es schon denkbar dass der der Übeltäter war. Ich werde berichten.
#14 vor 13 Tagen
Ghos7 1048 Beiträge
sh0rtround:Gar keinen. Hab ein Modem und eine Sophos UTM. Bin gerade dabei das Log auszuwerten. Es wäre halt mal geil wenn man von EAC mal erfahren würde welche ZielIPs und Ports man erreichen muss.


EAC ist nicht dokumentiert. Hab mir da auch mal n Wolf gesucht und nebenbei gesehen, dass EAC viele AWS outgoing zielpakete hat. wenn du keine geblockten requests hast, dann wird obv am PC schon iwas geblockt.
bei nem mate war es damals zB der "Kindersicherungs"-Schutz der Fritz.box. Lustigerweise hat man aber auch dort keine geblockten requests gesehen.
hast du noch andere enterprise produkte auf deinem PC? EAC ist halt intrusive as fuck, wenn du irgendwelche enterprise AVs hast oder deine UTM SPI macht, dann wird wird es nicht funktionieren. genauso, falls die sophos ssl offloading macht. sind alles faktoren die die EAC verbindung vmtl töten
kannst ja einfach mal den gegentest machen und an deiner sophos vorbei gehen, dann siehst woran es liegt.
und auch wenn du prinzipiell recht hast mit deiner aussage weiter oben, iamthewall liegt nicht weit daneben, dass ACs nicht für enterprise fws/proxies etc "gedacht" sind. du wirst nrigendwo genauere dokus finden bzgl der funktionsweise und wie wo welche sachen rausgeschickt werden und deine FW entsprechend nachkonfigurieren kannst - sowas funktioniert halt nur im enterprise umfeld und ACs leben uA davon, dass sie so wenig wie möglich dokumentiert werden ums der gegenseite schwieriger zu machen.
kann mir gut vorstellen, dass pakete gedroppt werden, die aber auch nicht auf EAC hindeuten wie du schon sagst, aber trotzdem zu eac gehören

gerade noch mal gesehen, dass du schon ne any any regel hattest - wenn deine proxy geschichte nicht funktioniert hat (was auch vollkommen logisch wäre, dass der verbindungsaufbau dann nicht klappt, AC traffic zu proxien macht 0 sinn), würd ich mal an deiner stelle richtung packet inspection und offloading schauen. und eben alternativ mal an deiner sophos vorbei gehen :) dann kannst du zmd deinen pc oder die sophos ausschließen
bearbeitet von Ghos7 am 12.03.2019, 13:54

Antwort posten

Um eine Antwort erstellen zu können, musst Du eingeloggt sein.
Freaks 4U Gaming © 2012-2019 by 99damage.de - All rights reserved. - Staff - Impressum - Datenschutz